WordPressで画像が表示されない問題再び!

WordPressで設定いじっているとおかしくなることはよくありますが(自分だけ!?)、また表示がおかしくなりました…

スポンサーリンク

Pixabay画像が表示されなくなった!

殴る

RyanMcGuire / Pixabay

久しぶりに記事を書いて公開しました!んで、投稿を確認してみると…ん?画像が表示されないぞ!?Pixabayの画像が表示されない!

実は以前に設定をあれこれいじっていた時、サイト高速化のためキャッシュ系をいじっていた際に画像が表示されなくなった事件がありました。

Wordpressで、サイトの表示速度が気になり…設定あれこれやったりプラグインあれこれ抜き差ししていたところ、気がついたらカエレバの商品表示が消えた!?原因と対策です。

それはそれでなんとか解決したんですが、今回は訳が違います。異なる点は、

設定をまるでいじっていない。正直、久しぶりに記事書いただけ。

ってところです。なんですか、天罰的なアレですか?人間始めたことはやめずにコツコツやらないと罰が当たる的な。

今回の画像が表示されない事象

現象としては、画像系がまるで表示されません。

・Pixabay画像:表示されない
・オリジナル画像:表示されない
・カエレバ画像:表示されない
・ヨメレバ画像:表示されない
・アプリーチ画像:表示されない

このような壊滅っぷり。ちなみに一応条件を書いておくと

WordPress:4.9.5 → 4.9.6
Theme:Simplicity2 Ver2.6.0.9

です。念のためWordPressのバージョンをあげてみましたがダメでした。一旦ハマると問題の切り分けが難しいんですよねー。

問題はプラグイン「Lazy Load」でした

とりあえずググってみたところ、あるサイトに答えがありました!

プラグインLazyLoadに関して不具合が起こったのでメモしておきます。 テーマによって相性が悪いプラグインが…

このサイトを参考に自サイトをチェックしてみました。まぁ結論はタイトル通りなんですけど。

JetpackのPhoton設定

前の問題の時に切ってました。なのでこれは問題なし。

Lazy Load設定

これはSimplicity2の機能としてONにしていました。外観→カスタマイズ→画像から「Lazy Load」機能のチェックボックスをOFF!

LazyLoad設定

と、機能をOFFにしたら画像が表示されるようになった!よかった!マジで!

まとめ

今回のようにLazy Loadが原因の場合、表示されるはずの画像領域に「1×1.trans.gif」が表示される現象となるようです。まずはLazy Loadがこのgif画像をはっつけておいて、後から正式画像を読み込むとか。いや、読み込んでよ!って感じですが読み込んでくれないとこのトラブルに繋がるみたいです。少しでもみなさんの助けになれれば幸いです。

search envelope heart star user close search-plus home clock update edit share-square chevron-left chevron-right leaf exclamation-triangle calendar comment thumb-tack link navicon aside angle-double-up angle-double-down angle-up angle-down star-half status image gallery music video category tag chat quote googleplus facebook instagram twitter rss